Skip to content

Cisco 877w with External Modem RFC 1493 or IPoATM

The following configuration is for BE Broadband / O2 Broadband Specific and will work with an external modem working on RFC1493 / Bridge mode.

When it comes to setting up a Cisco Router with a modem under bridge mode, you only need a Layer 3 port to configure the given IP Address. In any Layer 3 capable device, it is rather straight forward. To configure, you only needs to add the IP address, subnet mask to the interface; along with the default route to the ISP given default-gateway and it should work.

When it comes to the 877 / 877w etc, they only come with 4 Layer 2 capable switch port, therefore one needs to configure a VLAN Interface and assign one Switchport to the given VLAN as per following configuration.

You do not need to create a Dialer Interface as PPPoE/PPPoA is not involved in this configuration.

First, we setup FastEthernet3 as part of VLAN 20, which will be our VLAN Interface for the IPoATM Bridge.

interface FastEthernet3
 description EXTERNAL DSL IPoATM
 switchport access vlan 20
!

Then we setup Interface Vlan20 and add the IP Address & Subnet Mask given by the ISP.

interface Vlan20
 description EXTERNAL DSL IPoATM VLAN INTERFACE
 ip address 87.194.x.x 255.255.x.x
 ip nat outside
 ip virtual-reassembly
!

Then add the default route as follows. The Default-Gateway IP Address is given by the ISP.

ip route 0.0.0.0 0.0.0.0 87.194.x.x
!

And add the NAT Statements as follows. Interface VLAN 20 becomes the outside interface, as for Inside Interface, it could use be BVI/Dot11Radio etc

ip nat inside source list WIRED interface Vlan20 overload
ip nat inside source list WIRELESS interface Vlan20 overload
!
comments powered by Disqus